Mmastodon TechnologyCybersecurity first seen 3 d ago, last 3 d ago, peak #7
Node.js, Bun and Python rush out fixes for HTTP2Shell flaw
Original: Kürzlich ein System-Update gemacht? Node.js, Bun und Python bringen für HTTP2Shell (CVE-2026-111497) ihre eigene Brotli-
Developers are being urged to check their systems after a vulnerability tracked as CVE-2026-111497, dubbed HTTP2Shell, was addressed in new releases of Node.js, Bun and Python. The runtimes ship their own bundled copy of the Brotli compression library, so simply upgrading the system package libbrotli1 on Debian or Ubuntu is not enough. Users are advised to update to Node.js 22.23.4, 24.22.1 or 26.12.1, Bun 1.4.4, or the Brotli Python package 1.2.1 or later.
Why now: A newly disclosed security flaw affecting widely used runtimes has prompted urgent patch advisories, and administrators are verifying their installed versions.
Node.jsBunPythonCVE-2026-111497Brotli
Evidence
- Kürzlich ein System-Update gemacht? Node.js, Bun und Python bringen für HTTP2Shell (CVE-2026-111497) ihre eigene Brotli-Kopie mit, apt upgrade libbrotli1 reicht da nicht. node -v → sicher ab 22.23.4 / 24.22.1 / 26.12.1 bun --version → ab 1.4.4 pip show brotli → ab 1.2.1… · stackwatch@infosec.exchange · 3
API: https://socialmediatrends-api.osmike.com/v1/trends/3662914